Hogyan lehet frissíteni a GNOME 3.16 -ra az Ubuntu 15.04 -ben

instagram story viewer
gnome-316

Kíváncsi vagy, hogyan frissíthetsz GNOME 3.16 -ra az Ubuntu 15.04 -ben? Nos, itt vagyunk, hogy megmutassuk, hogyan kell (ha szeretné).

Bár a GNOME legújabb kiadása stabil, frissít rá a legújabb Ubuntu verzióra nem hátrányok nélkül.

Mielőtt elkezdenénk, összefoglaljuk, miért.

Miért nem szerepel a GNOME 3.16 az Ubuntu 15.04 -ben?

A stabil kiadás A GNOME 3.16 márciusban érkezett meg.

Jön egy csomó ügyes alkalmazásfrissítés, egy új megjelenésű „héj” és egy sima új értesítési központ. Nagyszerű dolgok, de túl későn érkeznek az Ubuntu fejlesztési ciklusába, hogy alapértelmezés szerint bekerüljenek az Ubuntu 15.04 -be.

Gnome-Unity-logó

Mivel a GNOME szerves része a hagyományos Unity asztalnak, amelyet milliók használnak a környéken, úgy döntöttünk, hogy ragaszkodunk a régebbi, de alaposan tesztelt GNOME 3.14 kiadáshoz.

Ha szeretné, frissítheti a GNOME 3.14 -et 3.16 -ra az Ubuntuban - de ez nem ajánlott.

A GNOME frissítése több alkalmazást és ikon témát tartalmaz. Az operációs rendszer régebbi, jól tesztelt összetevőit kicseréli az újabbakra, nagyrészt ENSZtesztelt cserék.

Ha entomofób (fantáziadús szó a hibáktól való félelemre), vagy gyűlöli a szoftveres fejfájást (erre nincs divatos szó), ez az oktatóanyag nem az Ön számára készült.

Ismétlem: frissíthet a GNOME 3.16 -ra az Ubuntu 15.04 de nem ajánlott és nem biztos, hogy stabil, megbízható élményt nyújt a végén.

Megértette?

Hogyan lehet frissíteni a GNOME 3.16 -ra az Ubuntu 15.04 -ben

gnóm-néző

Az útmutató helyes követéséhez már futtatnia kell a GNOME 3.14 -et az asztalon, ideális esetben az Ubuntu GNOME 15.04 legújabb verzióját (amely alapértelmezés szerint szállítja).

Frissíthet az Ubuntu 15.04 szokásos verzióiról is, de nem hazudhatok, mert nagy, de az útmutató követése teljesen tönkreteheti a Unity asztalt.

A Unity felhasználóknak a folytatás előtt telepíteniük kell a GNOME-Shell asztalt.

Telepítse a GNOME-Shell-t az Ubuntu 15.04-re

Azok, akik az Ubuntu régebbi verzióit futtatják, például 14.10 vagy 14.04 LTS, nem frissíthető a GNOME 3.16 -ra ezen útmutató követésével.

1. Adja hozzá a GNOME 3 Staging PPA -t

A frissítéshez hozzáadjuk a GNOME 3 Staging PPA. Ez az archívum kísérleti jellegű, és tartalmazza a frissítés végrehajtásához szükséges különféle 3.16 csomagok nagy részét, bár némileg nem tesztelt állapotban.

Ne adja hozzá ezt a PPA -t, ha stabil rendszerre van szüksége, ha valaki utálja a parancssort, vagy nem érzi magabiztosan a törött vagy ütköző csomagok javítását.

A GNOME 3 Staging PPA nem vállal garanciát, amint azt az archívum fenntartói ezzel az óvatossággal megjegyzik:

„A csomagokat [ebben a PPA -ban] úgy ítélték meg, hogy nem állnak készen az általános használatra, ismert hibákat és/vagy regressziókat tartalmaznak, amelyek néha kritikus jellegűek. Többnyire zökkenőmentesen kell működnie, de készüljön fel a ppa-purge használatára, ha problémákat tapasztal! ”

A szokásos GNOME 3 PPA megbízhatóbb, és a benne található csomagok „stabilnak” minősülnek. Ez a PPA egy bizonyos ponton a pontos GNOME 3.16 csomagokat tárolhatja jelenleg (általában a terv, de néha csak szakaszban maradnak).

Mielőtt azonban hozzáadnánk bármelyik PPA -t, tegyünk egy utolsó ellenőrzést (és telepítsünk minden elérhető) kiemelkedő forgalmazási frissítést:

sudo apt-get update && sudo apt-get dist-upgrade -y

Ezzel elkészíthetjük a szokásos GNOME 3 PPA -t és a GNOME 3 Staging PPA -t az Ubuntu szoftverforrásokhoz.

Ennek leggyorsabb módja a következő parancsok beírása a terminálon:

sudo add-apt-repository ppa: gnome3-team/gnome3-staging sudo add-apt-repository ppa: gnome3-team/gnome3. 

2. Frissítse a GNOME -t

A különböző PPA -k hozzáadása után szükségünk lesz a GNOME 3 frissítésére.

Vegyen egy mély lélegzetet, és futtassa a következő parancsot:

sudo apt-get update && sudo apt-get install gnome-shell gnome-session

Ügyeljen minden olyan értesítésre, amely a parancs futtatása után megjelenik a terminálon. A látottak megértésének szintje alapján döntse el, hogy folytatni kívánja -e

Ha örömmel adja meg a frissítést, bólogassa az enter billentyű megnyomásával.

A telepítési/frissítési folyamat megkezdődik.

Köszöntő üdvözlő?

a kijelzőkezelő ubuntu módosításaHa nem az Ubuntu GNOME -t futtatja, akkor a telepítési/frissítési folyamat során valamikor felkérik, hogy válasszon egy „alapértelmezett megjelenítéskezelőt” a listából.

A „kijelzőkezelő” kezeli a bejelentkezési képernyő élményét.

A tiszta GNOME élmény érdekében használja a billentyűzet nyílbillentyűit a megjelenő listából a „GDM” (GNOME Display Manager) bejegyzés kiválasztásához, majd nyomja meg az Enter billentyűt.

Az Ubuntu készlet bejelentkezési képernyőjén válassza a „lightdm” (Light Display Manager) lehetőséget, és nyomja meg az enter billentyűt.

Ne essen pánikba, ha rossz bejelentkezési kezelőt választ. tudsz módosítsa az alapértelmezett Ubuntu bejelentkezési kezelőt bármikor a következő paranccsal:

sudo dpkg-konfigurálja újra a lightdm fájlt

Ha kész, indítsa újra

ülések

Amikor a GNOME 3.16 befejezte a telepítést és/vagy a frissítést, újra kell indítania a számítógépet.

Erre azért van szükség, hogy az új telepített csomagok érvénybe lépjenek, például a kijelzőkezelő.

Ha nem GNOME asztali munkamenetből telepít vagy frissít ne felejtse el kiválasztani a GNOME munkamenetet a bejelentkezési képernyőn.

Ez az. Most (főleg) GNOME 3.16 -os rendszert kell futtatnia az Ubuntu -n.

De mehetünk egy kicsit tovább is.

Telepítsen néhány GNOME alkalmazást

Az Ubuntu GNOME alapértelmezés szerint egy csomó GNOME alkalmazással érkezik, de nem minden. Az Ubuntu szinte egyiket sem szállítja. T

A következő parancs telepít néhány lényeges elemet, beleértve Polari (IRC kliens), GNOME térképek (asztali térképészeti alkalmazás) és Web (könnyű webböngésző):

sudo apt-get install polari gnome-music gnome-photos gnome-maps gnome-weather epiphany-browser

Ennél több is rendelkezésre áll, de ezeknek a

Hogyan lehet visszalépni a GNOME 3.16 -ról a 3.14 -re

Emlékszel, mit mondtam arról, hogy ez a frissítés nem ajánlott? Te teszed? Jó.

Ha a GNOME 3.16 telepítése után jelentős problémákkal találkozik a rendszerével, akkor a PPA Purge eszközzel eltávolíthatja az átmeneti PPA -t és annak összes csomagját:

sudo apt-get install ppa-purge
sudo ppa-purge ppa: gnome3-team/gnome3-staging

Végül szabaduljon meg a szabványos GNOME 3 PPA -tól:

sudo ppa-purge ppa: gnome3-team/gnome3

Indítsa újra, és vissza kell térnie a GNOME asztal „stock” verziójához az Ubuntu 15.04 -ben.

Minden Ubuntu, naponta. 2009 óta.

Teachs.ru